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Creating Maps in QGIS: A Quick Guide  
 
Overview  
Quantum GIS, which is often called QGIS, is an open source GIS desktop application. Comparing to 
ArcGIS, QGIS can be installed on various operating systems, such as Windows, Mac OS X, Linux (Ubuntu), 
and Unix, while ArcGIS only has Windows version. More importantly, QGIS is FREE and has many plugins, 
adding different functions. However, since QGIS mainly relies on community support and voluntary 
developers, it does not have abundant documents and sometimes is not intuitive to use. Hence, making 
maps in QGIS needs some explanation. The two major steps, browsing data and making maps, are 
divided into five parts shown in the following table: 

No. Steps Sections 
to check 

Difficulties 

1 Load Geospatial Data into QGIS 1.1 Data formats 
2 Identify the features and attributes to 

present 
1.3  Layer order, feature selection, and 

(briefly) frequent-used projections 
3 Define how to show the data 2.2 Transparency (raster and vector), data 

classification, and layer file 
4 Add maps components 2.3 Geospatial data references 
5 Export maps 2.4 File formats 
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 Note: This document can be read in a “non-linear” manner:  
• Possible problems are covered in coloured regions: Knowing how to address these problems are not 

quite relevant to the main process, but might be useful in practise. Hence, they are covered in 
coloured regions, which you can skip when you want to go through the process and no error pops 
up. You can come back whenever you meet problems;  

• Section number and title is shown at the top of every page: If you have known what kind of problem 
you have, you can “jump” to the section where discusses it.  
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1.1 Load Data 
 

1. Browse Geospatial Data  
 
1.1. Load data  
 
To launch QGIS, click: Start -> All Programs -> QGIS -> QGIS. QGIS normally adds the version number 
after “QGIS”, which is currently 1.5.0 (code name Tethys). The main windows of QGIS can be divided 
into three regions shown in Figure 1. 
 

 
Figure 1. Structure of the Main Window of QGIS  

 

Click the Add Vector Layer  button to add geospatial data (Figure 2), which opens a window (Figure 
3). 
 

 
Figure 2. The Main Window : Add Vector Layer button 
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1.1 Load Data 

 
Figure 3. The Pop-up Window to "Add Vector Layer" 

 
Then you can browse to the file you want to work with by clicking the Browse button just like any other 
file explorer dialogs in Windows. You can open multiple files at one time by holding the Ctrl or Shift 
button when you are clicking the mouse button to make selections. The by-default file filter is *.shp file 
(Figure 4). But there are many other choices, such as *.kml (Google Earth) and *.tab (MapInfo), much 
broader than ArcGIS. 

 
 
 
 
 
 
 
 

 
Figure 4. The File Open Dialog  

 
Load all data listed in Figure 4 into QGIS. Please click the Open button just like any other file explorer 
dialogs in Windows to close the dialog. 

• Public_Schools.shp: All public school locations in the City of Waterloo; 
• waterloo_city.shp: The administrative boundary of the City of Waterloo; 
• waterloo_streets.shp: Street network in the City of Waterloo 

 
 

Add Raster Data: QGIS explicitly differentiates vector and raster data format. To add 

raster data, the Add Raster Layer button  should be clicked. The main reason is that raster 
data is supported via another open source module called GDAL, which adds powerful operations 
or raster data processing. 
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1.1 Load Data 
 

 
 
 
 
 
 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Frequently-used File Formats in QGIS: 
• Feature Data: Feature data are usually organized as points, lines, and polygons in vector 

format.  
o Shapefile: The most commonly used geospatial data format. Although it appears to be 

one file in ArcMap, shapefile includes multiple files with the same file name, but 
different extensions. *.shp, *.dbf, and *.shx are must-have. 

o Geodatabase: These files are based on Microsoft Access (*.mdb). From user 
perspective, all kinds of geodatabase are the same, which include multiple layers 
(different geospatial data) in one geodatabase.  

o MapInfo files: The following three are legendary geospatial file formats. MapInfo is 
the first desktop GIS software for Windows. Its files (*.tab) are widely used.  

o MicroStation files: MicroStation files have the extension of *.dgn, whose vendor is GE. 
Electricity plants often use it.  

o ArcInfo: ArcInfo is the previous generation of ArcGIS. Its file (*.e00) are supported in 
QGIS as well.  

o Google Earth: *.kml and *.kmz (zipped KML) are Google Earth file formats, which are 
popular in Location-Based Service now. Many websites support kml and kmz files.  

o GML and GeoJSON: Open source geospatial data standard, which is also popular in 
online applications.  

o GPS: The track of GPS records can be imported into QGIS as *.gpx files. This function is 
very useful in surveying.  

o CSV: *.csv files stands for comma separated value, which can be regarded as a 
legendary spreadsheet file format.  

o US Census TIGER: US census publishes its data in tiger format, which belongs to 
“directory” source type rather than “file”.  

• Raster Data: Raster data uses grid to represent a region with values as a “field”. Images 
explicitly have the parameter of resolution. Typical raster data is:  

o GeoTIFF: They have the file extension of *.tif. The key difference between normal TIFF 
file and GeoTIFF is that GeoTIFF has projection information. Hence, normal TIFF files 
cannot be correctly added to the desired location.  

o GeoJPEG: Similar to GeoTIFF, but they have *.jpg extension.  
o Usage: Raster data can be air photos, satellite images, elevation data (DEM). But 

raster data tends to be huge and slow to load.  
• Stronger Database Support:  

One major advantage of QGIS over ArcGIS lies in its superior support of different database 
vendors. Almost all types of relational database management system (RDBMS) are supported 



Page 5 of 25 
 

1.2 Add a Basemap 
 

1.2 Add a Basemap - Loading Goggle Maps  
 
QGIS provides the flexibility of using Google (or Yahoo, Bing etc) Satellite images as a background layer 
in your map. These come in the form of external Plugins. 
 
Too add a Basemap, go to Plugins -> Fetch Python Plugins¸ which leads to a dialog. 
 

 
Figure 5. Steps to add a Basemap layer 

 
Switch to the Repositories tab to ensure connection to the “QGIS Official Repository” have been 
established. Switch back to the Plugins tab and search for Openlayers (this can be done by typing 
“openlayers” in the filter), then select the “Openlayers plugin” and click the Install Plugin button.  
 

 
Figure 6. Plugin Installer Window 

 
Go back to menu Plugins -> Manage Plugins to ensure the plugin have been selected. Once selected, 
maps for this external extension, such as Google map layers, can be selected in the menu Plugins -> 
Openlayers plugin.  

 
Figure 7. Manage Plugins in Menu Bar 

 
*Please note there will not be Base maps in the Figures of this tutorial.  
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1.2 Add a Basemap 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Brief introduction to geographic information: 
• Vector Data: Vector data contains two parts: a geographic feature on the map (i.e. bus 

stops) and an associated record in the table with all its attributes (i.e. routes, arriving 
times, etc). The separation of attribute table and geographic feature is critical, because 
most operations in ArcGIS are organized based on this classification. 

• Raster Data: Raster data is a set of cells with values, which is normally added as reference 
background in mapping or included for further analysis. Normally, users will not identify or 
modify raster data for mapping purpose. 

• Networks: A kind of typical networks is roads. Finding the nearest way to a destination via 
roads is a frequently used operation. Please find more in the further reading if interested. 

• Further Reading: Michael Zeiler, Modeling Our World, ESRI Press, 2nd Edition, 2010. 
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1.3 Browse Geographic Features 
 
1.3. Browse Geographic Features 
 
Most controls to browse data are located in two tool bars (Figure 8), which are also available under the 
View menu. If you cannot find this toolbar, go to View -> Toolbars and check the Map Navigation on. 

 

 
Figure 8. The Toolbar with Data Browsing Controls 

 
Most icons are intuitive and self-explained. If you are not sure what function it has, hover your mouse 
over that icon. A pop-up text will show with further explanations.  
 
One difference between QGIS and ArcGIS is the layer related operations. In QGIS, all layer related 
operations must be conducted after the target layer has been selected, such as feature identification, 
feature selection, and attribute table operations.  
 
To open the attribute table, you can either right-click at the layer and select “Open attribute table”, or 
click the open attribute table button in the toolbar (Figure 9). 
 

 
Figure 9. The Pop-up Window with Options on a Layer 
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1.3 Browse Geographic Features 
 

 
Figure 10. Attribute Data Window 

There are many ways to choose a subset of features. Some options can be seen by clicking  , 
where the pop-up window displays different methods of feature selection (Figure 11). 
 

 
Figure 11. Selecting Features Options 

 
Another way is by right-clicking the layer, then selecting “Query” (Figure 12). You can form SQL 
statements to select features based on attributes. 
 

 
Figure 12. The Query Builder Window 

 
Another interesting feature is “Zoom to layer extent” shown in Figure 8. Sometimes you may lose sight 
of your map display. If so, you can zoom back to the desired region by clicking Zoom to layer extent.  
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1.3 Browse Geographic Features 
These controls can be classified and summarized into the following table: 
 

 Geographic Operations Attribute Operations 
Browse 

  
Right-click on the layer (Figure 6 and 7) 

Search/Identify  
 

Select 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Geospatial Data Projections: 
• The globe is not flat, but a map is. Any kind of projection used to make the map distorts the reality 

in some way. Hence, when Google maps or any other third party layer is included, different 
projections are likely to be used, leading to a problem of mismatch. 

• To obtain the projection information of a layer (and the map) right-click on the layer, then select 
Properties (Figure 9). Projection information is located under the General tab. 

 
• You can specify (check the projection code) by clicking the Specify CRS button. Frequently used 

projections are: 
o WGS 84: Used in GPS systems with longitude/latitude measurement. You can find it using 

either ESPG code 4326 or CRS ID 3452; 
o Google Mercator: Used by major online mapping services, including Google, Microsoft, 

and OpenStreetMap. Its ESPG code is 900913, while CRS ID 3644; 
o UTM zone system: UTM system is often employed in northern country mapping. 

Waterloo, Ontario, Canada belongs to UTM zone 17N, which can be found wit ESPG: 
26917 and CRS ID 2294.  

• If different layers cannot combine, go to the menu Settings -> Project Properties, and specify a 
project in the Coordinate Reference System (CRS) tab of the pop-up window. Check all layers’ 
projections if there are still problems. Mismatch is usually caused by incorrect use of projections. 
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2.1 Distinction between Geospatial Data and Map Components 
2. Mapping  
 
2.1. Distinction between Geospatial Data and Map Components 
 
Similar to ArcGIS, the mapping process is divided into two categories: Data view, which allows data 
manipulation and representation (symbology), and layout view, which provides functionality (i.e. legend, 
north arrow etc) and prepares a map for printing.  
 

• Data view: or the map canvas displays map layers and allows interaction with the map and 
layers through map tools. Some key operations include change of layer order, symbology 
customization, vector editing etc.  

• Layout view: Unlike ArcGIS, the layout view in QGIS is a tool called “Print Composer”. It is not as 
sophisticated as Arc’s layout view however allows the creation of maps and addition of essential 
map elements that can be printed or published. (See section 2.3 Map Components). 
 

 
Figure 13. Switch between Data View and Layout View 
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2.2. Key Options of Geospatial Data Representations 
 
2.2. Key Options of Geospatial Data Representations 
 
Main options of changing geospatial data representations include layer order, layer transparency, 
symbology, label, and annotation. Apart from the first one (layer order) and last one (annotations), all 
the rest are located in the pop-up window when you right-click the layer (Figure 14) and select 
Properties to modify. They are under either the Style (symbology) or Labels tab (Figure 15). 
 

 
Figure 14. Pop-up Window of a Layer's Property 

 

 
Figure 15. The Properties Window 

All options will be introduced as subsections in the following.  
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2.2 Key Options of Geospatial Data Representations 
 

2.2.1. Layer Order and Transparency 
 
The boundary layer (waterloo_city.shp) can be made as “halo” (no fill color) polygons allowing the 
overlaying basemap to be visible. The detailed steps will be introduced after the concept of layer order. 
Please note however, Figures in this tutorial do not include basemaps.  
 
Layer Order 
 
QGIS displays geospatial data according to the order in the table of contents: the bottom layer will be 
drawn on the screen first and covered by upper layers. Hence, the layer on the top in the table of 
contents will be displayed as the top layer in the map. Unlike ArcMap, QGIS will not order layers 
automatically.  
 
If two layers belong to the same feature class, i.e., point features, the newly added one will be on top of 
the older one.  
 
When a point-feature layer is put under a polygon-feature layer, the point-layer feature one is covered 
and invisible. You can change layer visibility by switching the checkboxes left to the layer name in table 
of contents (Figure 16). The display order can be changed by simply dragging the layer toward or away 
from the top.  

 
Figure 16. Layer Visibility and Order Control 
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2.2 Key Options of Geospatial Data Representations 
Layer Visibility 
 
When a polygon layer, such as buildings or parcels, is added over an image, the content on image under 
the building is often invisible. However users often like to only show the parcel’s boundary and keep the 
image displayed. In this case, layer transparency and hollow symbology can help.  
 
To do so, right-click on the polygon layer (waterloo_city) and select Properties first (Figure 15). Then 

switch to the tab Style and click  to get a pop-up window (Figure 17).  

 
Figure 17. Properties of Symbology 

 
When the pop-up window shows (Figure 18), you can make polygons hollow by changing Fill Style from 
Solid to No Brush, and increase Border Width.  

 
Figure 18. Make Hallow Polygons 
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2.2 Key Options of Geospatial Data Representations 
 
2.2.2. Symbology and Label 
 
Symbology is critical in making maps, which are classified into different categories in QGIS. Unlike 
ArcMap, QGIS does not hold a large library of professional symbols. In QGIS there are three types of 
symbols: 

• Marker symbols (for points) 
• Line symbols (for lines) 
• Fill and Outline symbols (for polygons) 

Each type of symbols can consist of one or more symbol layers.  
 
Please right-click the public_schools layer and select Properties. Then switch to the Style tab and click 

on the  (Figure 17). The pop-up window contains several different elements.  
 
Notice choosing different Symbol Layer Type will give different categorized symbols. In most cases, you 
will simply choose a symbol from the symbols available (other than making hallow polygons mentioned 
in 2.2.1). Depending on the type of the feature (point, line, or polygon) the options in Symbol Layer 
Type and Symbol Layer Properties change accordingly.  
 

 
Figure 19. Symbology Customization Window with Explanations 
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2.2 Key Options of Geospatial Data Representations  
 
 
 
 
 
 
 
There are cases when you want to differentiate features in a layer based on some attribute. For 
instance, I want to know which schools are public, separate, or for higher education in the schools layer; 
different types will be marked in colors. To do so, we should right-click on the school layer, select 
properties, and go to the Style tab, which is the same as shown in Figure 17. However, instead of by-
default Single Symbol option, we should click and select the categorized option. The steps to follow are 
also shown in Figure 20:   
 

1. Click on Single Symbol, and make sure Categorized is chosen; 
2. Pull down the dropbox of the Column field, and select TYPE as the classification attribute.  
3. (Optional) Click on the Color Ramp and/or Symbol dropbox and select your favourite color 

scheme and appropriate symbol. This must be done before adding all distinct values in step 4.  
*Note, some symbol layers (i.e. SVG Marker), have symbols that are color locked – meaning the 
color cannot be altered.  

4. Click on the Classify button to add all distinct values under the TYPE attribute into consideration 
 

 
Figure 20. Classifying Features using Colors 

 
The result is shown in Figure 21. Please note that you can still customize individual symbol for each 
category (size, shape, etc) by double clicking corresponding class on either the left pane or the line 
in the symbology window (Figure 21). The pop-up window is very similar to the window in Figure 20.  

Layer Transparency: 
An alternative (more generic) way of preventing overlaying is right-click the layer and select properties 
(Figure 15) first, and go to the Style tab (Figure 17). You can freely change the transparency as the 
parameter (percentage) of “Transparent” (or “Transparency” for raster layers).  
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2.2 Key Options of Geospatial Data Representations  
 

 
Figure 21. Classified Symbols and Further Customization 

 
Labels 
 
The labels are an important feature of a map. By marking some property up on the map, for stance, 
the name of the marked location, labels can make your map more useful, informative, and visually 
appealing.  
 
To add labels to your map, right-click on the layer that you want to add marks on (Public_Schools) 
and select Properties (Figure15). Then follow the steps below: 
 
1. Select the Labels tab and check on (off by default) “Display labels”.  
2. Choose the attribute you want to display on the map in the dropbox of Field Containing Label 

(Figure 22).  
3. Change Font, Font Size and other Placement options, so that it is clearly shown on the map.  
4. (Optional) If you think the added labels are not distinct on the map background, you can make a 

buffer background around the texts. Please scroll down and check Buffer Labels, which have the 
same effect of “mask” in ArcMap (Figure 23) 

5. You can click on the Apply button to see the effect until it is satisfactory. Then click on OK to 
save your setting and exit. 
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2.2 Key Options of Geospatial Data Representations 

 
Figure 22. Label Setting Window 

 

 
Figure 23. Change Mask Option for Clearer Labels 

*Note: Alternatively, you can accomplish most jobs by clicking  in the toolbar. Only the “buffer” 
function is missing.   
 
 
 
 
 
 
 

 
 
 
 
 
 
 

Symbology Types and Their Normal Usage 
• Single Symbol: Mainly used when you just want to mark geographic features on a map. 
• Categorized Symbol: also called Unique Values, gives every possible value of an attribute a 

distinct user-defined symbol (mainly based on colors). Categorized Symbol can be applied to 
all kinds of attributes.  

• Graduated Symbol: Graduated symbol marked attributes with decretive numbers in a 
statistical way, which can only be applied to attributes with numbers.  

• Rule Based: Condenses all the features from a layer with classification with rules that are 
based on simple SQL query language. 

• Diagram Overlay: Unlike ArcMap, QGIS places multiple attribute mapping into an 
independent tab called Diagrams. Information like the percentage of populations in 
different age intervals at different locations can be easily shown in this way.  
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2.2 Key Options of Geospatial Data Representations  
 
2.2.3. Annotations 
 
Annotations look like Labels. The key difference is that annotation can be any text you want to add 
on the map, regardless to whether the information has been included in the geospatial data.  
 
The tool can be found in the toolbar as shown in Figure 8.  
 

 
Figure 24. The Text Annotation Tool Options 

 
For instance, if you want to add a point at the entrance of uWaterloo, which is not in the geospatial 
data, click on the Text Annotation tool and type in the label in the pop-up window (Figure 25) 

 
Figure 25. Text Annotation Customization Options 
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2.3 Map Layout Components  
 

2.3. Map Layout and Map Components 
 
When the geospatial data and its representations are satisfactory, you can add other map 
components in another window via File -> Print Composer (Figure 26). You can manage multiple 
composers via File ->  Composer Manager.  
 
Key components of a map include: 

• The Title of the map (Purpose/Content); 
• The scale  of the map (Measurement); 
• The North Arrow (Orientation); 
• The Legend (how to interpret the map); 
• (Optional) The reference (where you obtain the data).  

 

 
Figure 26. The Map Composer Window 

 
Please note that, unlike ArcMap, the by-default page size is A4 (not letter size). Since letter size is more 
popular in North America, you might want to change the letter size, which is called “ANSI A”  in QGIS.  
 

 (Figure 26) adds the Main Map, and is done by clicking and dragging a rectangle on the paper to 
define display area and extent. 
 

 Map Titles and Citations can be added by using this tool to create text boxes. Click to automatically 
create a text box and then click on the spot where you want to place the title at. Create a separate text 
box for citations.  
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2.3 Map Layout Components  

 
In Print composer, you can customize the properties of all components by switching to the Item 
Properties tab. For instance, if you want to change the font of the title, click the title first (so that it is 
selected) and change to the Item Properties tab. There is a button called Font where you can find all the 
properties there.  

 
Figure 27. Text Box customization in Item Properties 

 

 
Figure 28. Customization in Item Properties Tab 
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2.3 Map Layout Components  
 

 Scale Bar: click on the tool and then select the spot you want the scale to be.  You can change map 
units and Style. The scale bar style can be numeric, i.e. 1:5,000,000, or different bar/line forms. All 
options are intuitive and can be tested by changing it back and forth. 
 

 
Figure 29.The Scale Bar (or Text) Property Window 

 

 North Arrow can be added as an arrow. The options of a north arrow in QGIS are very limited. 
 
 

 Legend can be added in the same way as others, click on the ‘Add New Legend’ tool. QGIS has 
better organization of legend properties than ArcMap. The Major options are located under Legend 
items. You can fine tune in General Options (Figure 30) 
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2.3 Map Layout Components  
 

 
Figure 30. The Legend Property Window 

 
The Legend tool automatically generates a legend based on all the layers available for the map – this is 
displayed in the Legend Items.  

• Add/Remove Layers: You can decide the layers to be added to the legend by clicking  to add 

or  to remove.  
• Change the Display Orders: The legend items will be added strictly in the order shown in the 

Legend Items pane. You can change the order by clicking a layer first and move it up  or 

move it down .  
• Change Layer Names: It is easy to find that the name displayed in the legend is difficult to 

understand. For instance, users won’t know what “waterloo_city” means. To change the name, 

you can select the layer, then click the edit button  and change it to a more meaningful 
name: City Boundary.  
 
Another method is to right-click on the “waterloo-city” layer in the table of content pane 
(Figure 15), and click Properties. Switch to the General tab and change the name in Display 
Name. Creating a new Legend will update the layer’s new name. You can use either method to 
change “waterloo_streets” to “Roads”. 
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2.3 Map Layout Components  
 

 
Figure 31. The General Tab to Change Layer Name 

 
 

 
Figure 32. An Example of Legend after Customization 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Some Components that are also frequently added: 
• Author of the Map: Users may want to know who creates the map; 
• Data Saved (Created/Modified): The more frequent a region changes, the more important it is 

for users to know when the map is created; 
• Coordinate System: The globe is not flat, but a map is. Any kind of projection used to make the 

map distorts the reality in some way. Hence, it is critical for users to know how reliable their 
measurements on the map are, especially for pilots and navigators.  
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2.4 Export Maps  
2.4. Export Maps  
 
When you are satisfied with everything on the map and are ready to deliver, you can export your map as 
images, PDF, SVG, or print a hard copy. All options are under the File menu.  
 

 
Figure 33. Export Map Options 

 
You can specify the directory and file name of the map in this dialog. Most importantly, you need to 
choose an appropriate file format by clicking on the Save as type dropbox. The most frequent-used 
formats are JPEG and PDF. JPEG is a popular graphic file format, which is easy to be inserted into word 
as a graph, while PDF is best used for sharing. The printed copy of PDF will be identical regardless of 
your computer (and printer) environment.  

 

 
Figure 34. Export Map Dialog 

 
 
Please note that if the purpose of your map is to be shown on screen, 96 dpi resolution is good enough. 
It is especially true when you want to publish your map online, given that lower resolution maps are 
much smaller, and therefore, easier to transfer via Internet. If you need hard copies of your map, please 
make sure that the resolution is set to 300 dpi or 600 dpi (Figure 35). Otherwise the output map might 
be obscure.  
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2.4 Export Maps  
 

 
Figure 35. General Customization on Print Composer 

 
Other than export map to other file formats, you can directly print out hardcopies of your map by File -> 
Print. You can also customize page and printer setup via File -> Page Setup, such as page orientation 
(portrait and landscape), page size and so on. All these operations are intuitive and very similar to other 
applications, such as Microsoft Word. 

 
 
 
 
 
 
 
 
 
 
 

 
 
 

 

  

Created by Bonnie Lui in 2013 

Brief Explanation of Graphic File Formats: 
• SVG file: Scalable Vector Graphics, an open-source vector graphic standard. It is becoming 

more and more popular and can be accepted by many vendors;  
• BMP file: BitMap file, which is a mature loss-less uncompressed raster format. The quality is 

great. But its file size tends to be huge. It can be used if you need both high-quality output 
and compatibility;  

• PNG file: Portable Network Graphics, which is an open-source standard designed to replace 
BMP and GIF. It is a true-color loss-less raster file format. PNG file is slightly larger than JPEG 
(compressed with quality loss). And some old browsers and operating systems do not 
support PNG files;  

• TIFF file: Tagged Image File Format. A major raster graphic file format provided by Adobe (AI 
for vector). Best to be used for raster file editing on Adobe Products, such as Photoshop;  

• GIF file: Graphics Interchange Format. An uncompressed raster file format with 256-color 
limitation. Hence, if your map contains only a few colors (vector-based data), GIF is a good 
candidate.  

 
  


